import re
regex = re.compile(r"(?:[-x+]\h*may(?:15)?|may(?:15)?\h*[-x+])(*SKIP)(*F)|may(?:15)?", flags=re.IGNORECASE)
test_str = ("x May15 > WRONG\n"
"- May15 > WRONG\n"
"+ May15 > WRONG\n"
"xMay15 > WRONG\n"
"-May15 > WRONG\n"
"+May15 > WRONG\n"
"May15 > TRUE\n"
"May15, > TRUE\n"
"May15 + > FALSE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")