package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+(?:[- ]\w+)*`)
var str = `Some Words - Other Words (More Words) Dash-Binded-Word`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}