$re = '/\w+(?:[- ]\w+)*/';
$str = 'Some Words - Other Words (More Words) Dash-Binded-Word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);