const regex = /<input\s.*(?:type=['"]?hidden['"]?).*"?required"?.*\s?\/?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<input\\s.*(?:type=[\'"]?hidden[\'"]?).*"?required"?.*\\s?\\\/?>', 'g')
const str = `<input type="hidden" class="required row" value="hello" required="required">
<input type="hidden" class="required row" value="hello" required >
<input class="required digits" type="hidden" name="WC_NMA_host" id="wc_nma_host" size="6" maxlength="5" required=required value="12" />
<input class="required digits" type="hidden" name="WC_NMA_host" id="wc_nma_host" size="6" maxlength="5" required value="12" />
<input class="required digits" type="hidden" required name="WC_NMA_host" id="wc_nma_host" size="6" maxlength="5" value="12" />
<input type="hidden" class="required row" value="hello" required />
<input type="hidden" class="required row" value="hello" required>
<input type='hidden' class="required row" value="hello" required>
<input type='hidden' class="row" value="hello" required>
<input class="required digits" type="hidden" name="WC_NMA_host" id="wc_nma_host" size="6" maxlength="5" value="12" required />
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}