import re
regex = re.compile(r"<input\s.*(?:type=['\"]?hidden['\"]?).*\"?required\"?.*\s?\/?>")
test_str = ("<input type=\"hidden\" class=\"required row\" value=\"hello\" required=\"required\">\n\n"
"<input type=\"hidden\" class=\"required row\" value=\"hello\" required >\n\n"
"<input class=\"required digits\" type=\"hidden\" name=\"WC_NMA_host\" id=\"wc_nma_host\" size=\"6\" maxlength=\"5\" required=required value=\"12\" />\n\n"
"<input class=\"required digits\" type=\"hidden\" name=\"WC_NMA_host\" id=\"wc_nma_host\" size=\"6\" maxlength=\"5\" required value=\"12\" />\n\n"
"<input class=\"required digits\" type=\"hidden\" required name=\"WC_NMA_host\" id=\"wc_nma_host\" size=\"6\" maxlength=\"5\" value=\"12\" />\n\n"
"<input type=\"hidden\" class=\"required row\" value=\"hello\" required />\n\n"
"<input type=\"hidden\" class=\"required row\" value=\"hello\" required>\n\n"
"<input type='hidden' class=\"required row\" value=\"hello\" required>\n\n"
"<input type='hidden' class=\"row\" value=\"hello\" required>\n\n"
"<input class=\"required digits\" type=\"hidden\" name=\"WC_NMA_host\" id=\"wc_nma_host\" size=\"6\" maxlength=\"5\" value=\"12\" required />\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")