$re = '/<input\s.*(?:type=[\'"]?hidden[\'"]?).*"?required"?.*\s?\/?>/';
$str = '<input type="hidden" class="required row" value="hello" required="required">
<input type="hidden" class="required row" value="hello" required >
<input class="required digits" type="hidden" name="WC_NMA_host" id="wc_nma_host" size="6" maxlength="5" required=required value="12" />
<input class="required digits" type="hidden" name="WC_NMA_host" id="wc_nma_host" size="6" maxlength="5" required value="12" />
<input class="required digits" type="hidden" required name="WC_NMA_host" id="wc_nma_host" size="6" maxlength="5" value="12" />
<input type="hidden" class="required row" value="hello" required />
<input type="hidden" class="required row" value="hello" required>
<input type=\'hidden\' class="required row" value="hello" required>
<input type=\'hidden\' class="row" value="hello" required>
<input class="required digits" type="hidden" name="WC_NMA_host" id="wc_nma_host" size="6" maxlength="5" value="12" required />
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);