import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<meta\\s[^>]*?name\\s*=[\\s\"']+description[\\s\"']+content\\s*=\\s*(?:'(?<content>.*?)'|\"(?<content>.*?)\")";
final String string = "<title>Design Custom Drinkware | Deluxe.ca </title>\n"
+ "<meta name=\"description\" content=\"Customize drinkware from thousands of cups, mugs, koozies, and water bottles from popular brands. Personalize with your logo, image, or message to create promotional gifts they'll love. \"/>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}