re = /<meta\s[^>]*?name\s*=[\s"']+description[\s"']+content\s*=\s*(?:'(?<content>.*?)'|"(?<content>.*?)")/
str = '<title>Design Custom Drinkware | Deluxe.ca </title>
<meta name="description" content="Customize drinkware from thousands of cups, mugs, koozies, and water bottles from popular brands. Personalize with your logo, image, or message to create promotional gifts they\'ll love. "/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end