// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)<meta\s[^>]*?name\s*=[\s"']+description[\s"']+content\s*=\s*(?:'(?<content>.*?)'|"(?<content>.*?)")"#).unwrap();
let string = "<title>Design Custom Drinkware | Deluxe.ca </title>
<meta name=\"description\" content=\"Customize drinkware from thousands of cups, mugs, koozies, and water bottles from popular brands. Personalize with your logo, image, or message to create promotional gifts they'll love. \"/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}