$re = '/\b(?:(?!true|false))\w+\b/';
$str = '"O_1324||T_6789||EC_67889&&(IC_12345||chicken)||true&&false"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);