re = /\b(?:(?!true|false))\w+\b/
str = '"O_1324||T_6789||EC_67889&&(IC_12345||chicken)||true&&false"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end