using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(1[0-9]{2})|(2([0-4][0-9]|5[0-5]))|([1-9][0-9]?)";
string input = @"101
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}