package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(1[0-9]{2})|(2([0-4][0-9]|5[0-5]))|([1-9][0-9]?)`)
var str = `101
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}