$re = '/(1[0-9]{2})|(2([0-4][0-9]|5[0-5]))|([1-9][0-9]?)/';
$str = '101
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);