import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\$var(?=(?:(?!\\/\\*|\\*\\/).)*\\*\\/)";
final String string = "/* other code */\n"
+ "$var = .... ;\n\n"
+ "/* \n"
+ "other code\n"
+ "$var = .... ;\n"
+ "other code\n"
+ "*/\n\n"
+ "$var = .... ;\n"
+ "$var = \"*/\"\n"
+ "/* \n"
+ "other * code /\n"
+ "$var = .... ;\n"
+ "other code\n"
+ "*/\n\n"
+ "// These should not match\n\n"
+ "$var = \"*/\";\n\n"
+ "$var = ...;\n"
+ "// */";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}