$re = '/(?s)\$var(?=(?:(?!\/\*|\*\/).)*\*\/)/';
$str = '/* other code */
$var = .... ;
/*
other code
$var = .... ;
other code
*/
$var = .... ;
$var = "*/"
/*
other * code /
$var = .... ;
other code
*/
// These should not match
$var = "*/";
$var = ...;
// */';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);