re = /(?s)\$var(?=(?:(?!\/\*|\*\/).)*\*\/)/
str = '/* other code */
$var = .... ;
/*
other code
$var = .... ;
other code
*/
$var = .... ;
$var = "*/"
/*
other * code /
$var = .... ;
other code
*/
// These should not match
$var = "*/";
$var = ...;
// */'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end