import re
regex = re.compile(r"\[([^\[\]]*?)\]\((\S*?)\)", flags=re.DOTALL | re.IGNORECASE)
test_str = ("# Basic Cases\n\n"
"[test link](http://test.com)\n\n"
"[test-link@test.com](http://test.com/test-link)\n\n"
"[title (parenthesis)](http://www.test.com)\n\n"
"[relative link](/test-link/page)\n\n"
"[anchor reference](#reference)\n\n"
"[title with\n"
"linebreak](http://test.com)\n\n"
"# Extra Cases\n\n"
"[]()\n\n"
"[](uri:empty-title)\n\n"
"[[extra sq bracket](ftp://test.com)\n\n"
"[extra sq bracket - invalid]](https://test.com)\n\n"
"[extra parentheses](((())))\n\n"
"[link with linebreak - invalid](http:\n"
"//test.com)\n\n"
"# Lazy Delimiter Testing\n\n"
"[()][()][(][)[][]))([()[(((][(]][)([(])))[()\n\n"
"[((()))]()\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")