import Foundation
let pattern = #"\[([^\[\]]*?)\]\((\S*?)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = ##"""
# Basic Cases
[test link](http://test.com)
[test-link@test.com](http://test.com/test-link)
[title (parenthesis)](http://www.test.com)
[relative link](/test-link/page)
[anchor reference](#reference)
[title with
linebreak](http://test.com)
# Extra Cases
[]()
[](uri:empty-title)
[[extra sq bracket](ftp://test.com)
[extra sq bracket - invalid]](https://test.com)
[extra parentheses](((())))
[link with linebreak - invalid](http:
//test.com)
# Lazy Delimiter Testing
[()][()][(][)[][]))([()[(((][(]][)([(])))[()
[((()))]()
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)