import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{1,4}|(?=\\d*[a-zA-Z]\\d*$)[\\da-zA-Z]{2,5})$";
final String string = "1234\n"
+ "123u4\n"
+ "12u34\n"
+ "1u234\n"
+ "u1234\n"
+ "1243u\n"
+ "u\n"
+ "1\n"
+ "1un";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}