const regex = /^(?:\d{1,4}|(?=\d*[a-zA-Z]\d*$)[\da-zA-Z]{2,5})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{1,4}|(?=\\d*[a-zA-Z]\\d*$)[\\da-zA-Z]{2,5})$', 'gm')
const str = `1234
123u4
12u34
1u234
u1234
1243u
u
1
1un`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}