$re = '/^(?:\d{1,4}|(?=\d*[a-zA-Z]\d*$)[\da-zA-Z]{2,5})$/m';
$str = '1234
123u4
12u34
1u234
u1234
1243u
u
1
1un';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);