import re
regex = re.compile(r"\s*sources\s*:\s*\[(.*?)\]", flags=re.MULTILINE)
test_str = ("var player = new Clappr.Player({\n"
" sources: [\"https://c8.videobin.co/hls/oudvgdb4lvtk2yixv7joeclsl26zirhqupniofc7s,rqmgzeecwdox4infaoa,icmgzeecwdjhatedksa,.urlset/master.m3u8\",\"https://c8.videobin.co/oudvgdb4lvtk2yixv7joeclsl26zirhqupniofc7sicmgzeecwdjhatedksa/v.mp4\",\"https://c8.videobin.co/oudvgdb4lvtk2yixv7joeclsl26zirhqupniofc7srqmgzeecwdox4infaoa/v.mp4\"], \n"
" poster: \"https://c8.videobin.co/i/01/00010/m5pbbn9strm5_xt.jpg\", \n"
" width: \"100%\",\n"
" height: \"100%\",\n"
" disableVideoTagContextMenu: true,\n"
" maxBufferLength: 15,\n"
" parentId: \"#vplayer\"\n"
" ,plugins: {\"core\": [ClapprThumbnailsPlugin,LevelSelector]}\n"
" ,scrubThumbnails: {\n"
" backdropHeight: 60,\n"
" spotlightHeight: 60,\n"
" thumbs: thumbs\n"
" },maxBufferLength: 15,levelSelectorConfig: {\n"
" title: 'Quality',\n"
" labels: {\n"
" 3: 'Higher',\n"
" 2: '1080p',\n"
" 1: '720p',\n"
" 0: '480p',\n"
" }\n"
" }\n"
" });")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")