re = /\s*sources\s*:\s*\[(.*?)\]/m
str = 'var player = new Clappr.Player({
	sources: ["https://c8.videobin.co/hls/oudvgdb4lvtk2yixv7joeclsl26zirhqupniofc7s,rqmgzeecwdox4infaoa,icmgzeecwdjhatedksa,.urlset/master.m3u8","https://c8.videobin.co/oudvgdb4lvtk2yixv7joeclsl26zirhqupniofc7sicmgzeecwdjhatedksa/v.mp4","https://c8.videobin.co/oudvgdb4lvtk2yixv7joeclsl26zirhqupniofc7srqmgzeecwdox4infaoa/v.mp4"], 
	poster: "https://c8.videobin.co/i/01/00010/m5pbbn9strm5_xt.jpg", 
	width: "100%",
    height: "100%",
    disableVideoTagContextMenu: true,
	maxBufferLength: 15,
	parentId: "#vplayer"
	,plugins: {"core": [ClapprThumbnailsPlugin,LevelSelector]}
	,scrubThumbnails: {
        backdropHeight: 60,
        spotlightHeight: 60,
        thumbs: thumbs
      },maxBufferLength: 15,levelSelectorConfig: {
    title: \'Quality\',
    labels: {
        3: \'Higher\',
        2: \'1080p\',
        1: \'720p\',
        0: \'480p\',
    }
  }
	});'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end