using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\da-zA-Z]+[^\da-zA-Z]+)";
string input = @"Zombie_Hip
Zombie_RightLeg
Zombie_LeftArm
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}