package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\da-zA-Z]+[^\da-zA-Z]+)`)
var str = `Zombie_Hip
Zombie_RightLeg
Zombie_LeftArm
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}