$re = '/^([\da-zA-Z]+[^\da-zA-Z]+)/m';
$str = 'Zombie_Hip
Zombie_RightLeg
Zombie_LeftArm
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);