#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "id="address">(.*?)<|<br>(.*?) : (.*?)<br>|(?<=<br>)(.*?)&|(\$[^&]+)"
Local $sString = "<strong id="address">1245 DUPONT ST</strong><br>Toronto : Metro Toronto<br>14 Aug 2015 $71,000,000 <font color="#CC0000"></font>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")