using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"id=""address"">(.*?)<|<br>(.*?) : (.*?)<br>|(?<=<br>)(.*?)&|(\$[^&]+)";
string input = @"<strong id=""address"">1245 DUPONT ST</strong><br>Toronto : Metro Toronto<br>14 Aug 2015 $71,000,000 <font color=""#CC0000""></font>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}