import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "id=\"address\">(.*?)<|<br>(.*?) : (.*?)<br>|(?<=<br>)(.*?)&|(\\$[^&]+)";
final String string = "<strong id=\"address\">1245 DUPONT ST</strong><br>Toronto : Metro Toronto<br>14 Aug 2015 $71,000,000 <font color=\"#CC0000\"></font>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}