#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+?(?:(84|0))(\s?[\-\u2010\u2011\u2012\u2013\u2014\u2015]?\s?)[357-9]\d{6}(?:\d{2}(?:\d{1})?)?)"
Local $sString = "1234567" & @CRLF & _
"76543211234" & @CRLF & _
"123456789" & @CRLF & _
"12345778" & @CRLF & _
"1234567890" & @CRLF & _
"+8412345678" & @CRLF & _
"84123456789" & @CRLF & _
"8412345" & @CRLF & _
"84123456" & @CRLF & _
"+1234567" & @CRLF & _
"+84" & @CRLF & _
"" & @CRLF & _
"0123456" & @CRLF & _
"" & @CRLF & _
"+84356763987" & @CRLF & _
"5123456" & @CRLF & _
"31234567" & @CRLF & _
"712345678" & @CRLF & _
"9123456789" & @CRLF & _
"+84-5123456" & @CRLF & _
"+84 5123456" & @CRLF & _
"05123456" & @CRLF & _
"0-5123456" & @CRLF & _
"+84 - 5123456" & @CRLF & _
"843378262" & @CRLF & _
"84337671542" & @CRLF & _
"84575516147" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")