using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Version: (\d+\.\d+.\d+\.\d+)\.\d+";
string input = @"Version: 4.4.0.157.165";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}