const regex = new RegExp('Version: (\\d+\\.\\d+.\\d+\\.\\d+)\\.\\d+', 's')
const str = `Version: 4.4.0.157.165`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}