re = /(?=.*(\QE\\){2}z\/\z)^\/\(\?\=\.\*\(\\Q.{76}\E\\){2}z\/\z)^\/\(\?\=\.\*\(\\Q.{76}\z/
str = '/(?=.*(\\QE\\\\){2}z\\/\\z)^\\/\\(\\?\\=\\.\\*\\(\\\\Q.{76}\\E\\\\){2}z\\/\\z)^\\/\\(\\?\\=\\.\\*\\(\\\\Q.{76}\\z/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end