const regex = /(?:^)(?:[^d][^e][^f])+\(/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^)(?:[^d][^e][^f])+\\(', 'gm')
const str = `def a(self)
def ab(self)
def abc(self)
def abcd(self)
a(self)
ab(self)
abc(self)
abcd(self)
It should not match lines with:
anything def anything(thing)
And only match lines as:
anything anything(thing)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}