import re
regex = re.compile(r"(?:^)(?:[^d][^e][^f])+\(", flags=re.MULTILINE)
test_str = ("def a(self)\n"
"def ab(self)\n"
"def abc(self)\n"
"def abcd(self)\n\n"
"a(self)\n"
"ab(self)\n"
"abc(self)\n"
"abcd(self)\n\n"
"It should not match lines with: \n\n"
" anything def anything(thing) \n\n"
"And only match lines as:\n\n"
" anything anything(thing)\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")