import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<year>\\d{4})[\\-\\.\\/]?(?<month>0[1-9]|1[02])[\\-\\.\\/]?(?<day>[0-2]\\d|3[0-1])[ T]?(?<hour>[0-1]\\d|2[0-3])[\\:\\.]?(?<minute>[0-5]\\d)[\\:\\.]?(?<second>[0-5]\\d) ?(?<offset>(?<offset_sign>[\\-\\+]*)(?<offset_hour>0[0-9]|1[0-2])[\\:\\.]?(?<offset_minute>[0-5]\\d))";
final String string = "--- SHOULD MATCH ---\n"
+ "20181215144545-06:00\n"
+ "2018-12-15T14:45:45 -06:00\n"
+ "2018-12-15 14:45:45 -06:00\n"
+ "2018.12.15T14.45.45 -06:00\n"
+ "2018.12.15T14.45.45-06.00\n"
+ "2018/12/15T14:45:45-06:00\n"
+ "201812151445450000\n"
+ "103212150000000000\n"
+ "103212151111111111\n"
+ "103212152222221222\n"
+ "--- SHOULD NOT MATCH ---\n"
+ "2018-13-15T14:45:45 -06:00\n"
+ "2018-12-60T14:45:45 -06:00\n"
+ "2018-12-15T24:45:45 -06:00\n"
+ "2018-12-15T14:60:45 -06:00\n"
+ "103212152222222222\n"
+ "103212152222221322";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}