use strict;
my $str = '--- SHOULD MATCH ---
20181215144545-06:00
2018-12-15T14:45:45 -06:00
2018-12-15 14:45:45 -06:00
2018.12.15T14.45.45 -06:00
2018.12.15T14.45.45-06.00
2018/12/15T14:45:45-06:00
201812151445450000
103212150000000000
103212151111111111
103212152222221222
--- SHOULD NOT MATCH ---
2018-13-15T14:45:45 -06:00
2018-12-60T14:45:45 -06:00
2018-12-15T24:45:45 -06:00
2018-12-15T14:60:45 -06:00
103212152222222222
103212152222221322';
my $regex = qr/^(?<year>\d{4})[\-\.\/]?(?<month>0[1-9]|1[02])[\-\.\/]?(?<day>[0-2]\d|3[0-1])[ T]?(?<hour>[0-1]\d|2[0-3])[\:\.]?(?<minute>[0-5]\d)[\:\.]?(?<second>[0-5]\d) ?(?<offset>(?<offset_sign>[\-\+]*)(?<offset_hour>0[0-9]|1[0-2])[\:\.]?(?<offset_minute>[0-5]\d))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}