# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<year>\d{4})[\-\.\/]?(?<month>0[1-9]|1[02])[\-\.\/]?(?<day>[0-2]\d|3[0-1])[ T]?(?<hour>[0-1]\d|2[0-3])[\:\.]?(?<minute>[0-5]\d)[\:\.]?(?<second>[0-5]\d) ?(?<offset>(?<offset_sign>[\-\+]*)(?<offset_hour>0[0-9]|1[0-2])[\:\.]?(?<offset_minute>[0-5]\d))"
test_str = ("--- SHOULD MATCH ---\n"
"20181215144545-06:00\n"
"2018-12-15T14:45:45 -06:00\n"
"2018-12-15 14:45:45 -06:00\n"
"2018.12.15T14.45.45 -06:00\n"
"2018.12.15T14.45.45-06.00\n"
"2018/12/15T14:45:45-06:00\n"
"201812151445450000\n"
"103212150000000000\n"
"103212151111111111\n"
"103212152222221222\n"
"--- SHOULD NOT MATCH ---\n"
"2018-13-15T14:45:45 -06:00\n"
"2018-12-60T14:45:45 -06:00\n"
"2018-12-15T24:45:45 -06:00\n"
"2018-12-15T14:60:45 -06:00\n"
"103212152222222222\n"
"103212152222221322")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.