package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b[A-z]+[A-z]*kowie[A-z]*)`)
var str = `asikowiecz
asikowie
Asikowierzyn
askowie
Askowierzyn
sikowie
Sikowierzyn
skowie
Skowierzyn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}