import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b[A-z]+[A-z]*kowie[A-z]*)";
final String string = "asikowiecz\n"
+ "asikowie\n"
+ "Asikowierzyn\n"
+ "askowie\n"
+ "Askowierzyn\n"
+ "sikowie\n"
+ "Sikowierzyn\n"
+ "skowie\n"
+ "Skowierzyn";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}