re = /(\b[A-z]+[A-z]*kowie[A-z]*)/
str = 'asikowiecz
asikowie
Asikowierzyn
askowie
Askowierzyn
sikowie
Sikowierzyn
skowie
Skowierzyn'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end