#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ui)(?<=республика)([\s\S]*?)(?=край)"
Local $sString = "Адрес:" & @CRLF & _
"Республика ХХХХХХХ" & @CRLF & _
"ХХХХХ" & @CRLF & _
"ХХХХХ" & @CRLF & _
"Край(область) ХХХХХХ " & @CRLF & _
"Район ХХХХХХХХ " & @CRLF & _
"Нас.пункт ХХХХХХХХХ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")