using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=республика)([\s\S]*?)(?=край)";
string input = @"Адрес:
Республика ХХХХХХХ
ХХХХХ
ХХХХХ
Край(область) ХХХХХХ
Район ХХХХХХХХ
Нас.пункт ХХХХХХХХХ";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}