$re = '/(?<=республика)([\s\S]*?)(?=край)/ui';
$str = 'Адрес:
Республика ХХХХХХХ
ХХХХХ
ХХХХХ
Край(область) ХХХХХХ
Район ХХХХХХХХ
Нас.пункт ХХХХХХХХХ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);