using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\D{5}\d{4}\D\b";
string input = @"pan number : ASDFG4356P
pan number : WERTSDFG4356P
pan number : DFG4356P
pan number : ASDFG4356PRTE
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}