package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\D{5}\d{4}\D\b`)
var str = `pan number : ASDFG4356P
pan number : WERTSDFG4356P
pan number : DFG4356P
pan number : ASDFG4356PRTE
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}