package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s(\d+)\s`)
var str = `int_test: "Today is 6/28/2017 with 17.5 percent chance of rain 2 23.3 345 "
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}