$re = '/\s(\d+)\s/m';
$str = 'int_test: "Today is 6/28/2017 with 17.5 percent chance of rain 2 23.3 345 "
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);