re = /\s(\d+)\s/m
str = 'int_test: "Today is 6/28/2017 with 17.5 percent chance of rain 2 23.3 345 "
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end